BE error code: class not registered

This is the place for questions about things electrical and mechnanical...or any other automotive-related hardware issue.

Moderators: cgrey8, EDS50, Jon 94GT, 2Shaker

Post Reply
93foxturbo
Gear Head
Posts: 44
Joined: Tue Aug 12, 2008 7:22 pm

BE error code: class not registered

Post by 93foxturbo » Mon Feb 13, 2017 7:33 pm

hi everyone, I have recently purchased BE/EA(with tweecer and innovate). I have been slowly modifying my current tune(idle table to start for now until weather gets better). Yesterday however, when I turned on my laptop and started BE, I got this error code "Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG))"
I have also noticed in status(bottom), it now says "hardware changed to tweecer". When I do go into hardware tab, I noticed innovate option is no longer available. Another thing I saw is in the main BE screen, everything is shifted towards the left(as if zoomed out) and when I click dash 1 or dash 2 tabs, both come up blank.
Any ideas? I was thinking to re-install BE but would I need to get another license from clint or the previous one will still work?
1993 coupe- 408, built AOD, 3500 stall, 4.10 gears, 42's, 80mm c&l, a3m, GUFB, tweecer/innovate lm-1, BE EA

sailorbob
BIN Hacker
Posts: 1641
Joined: Tue Jul 12, 2005 6:10 am

Re: BE error code: class not registered

Post by sailorbob » Tue Feb 14, 2017 5:45 am

You won't need to buy another license. Contact Clint, he'll be able to say what the problem is.

93foxturbo
Gear Head
Posts: 44
Joined: Tue Aug 12, 2008 7:22 pm

Re: BE error code: class not registered

Post by 93foxturbo » Sun Feb 19, 2017 3:47 am

Thanks for the help. I ended up emailing Clint and he responded right away and resolved the issue. Turns out I needed to download logworks. Couple of nights before, my laptop did some updates so I am assuming that's what caused my issue.
I am still unable to log AFR in BE, but I will start a new thread in software section.
I figured I will update for anyone else is having same issue so that it pops up in search.
1993 coupe- 408, built AOD, 3500 stall, 4.10 gears, 42's, 80mm c&l, a3m, GUFB, tweecer/innovate lm-1, BE EA

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests