Looking for adx/data logging help!

Errors, Crashes, and Bugs, Oh My! This is where issues specific to tuning software goes. General questions about software features & capabilities are also welcome here.

Moderators: cgrey8, EDS50, Jon 94GT, 2Shaker

Post Reply
davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Looking for adx/data logging help!

Post by davidsmcneill » Fri Mar 23, 2018 8:03 pm

I've got a QH (1.6Q) that I have hooked up to a 8LD (GUFA) computer and I'm running TunerProRT software. I've been able to modify and upload the bin (8LD) to the QH, but I'm having issues getting the data logging working. I'm currently using the DECIPHA_EEC-IV_QH_20171109.adx file, but not having much luck. I don't get any movement on any of the gauges. I do get the 'DA: connected' and a bitrate when I click on the connect data button, but nothing ever changes on the gauges regardless of what dashboard I select. I've tried it KOEO and KOER. I'm not sure if this matters, but the bin file that I am currently running was a 56k file, so I had to modify the xdf header to read it correctly. Any suggestions would be appreciated!
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

User avatar
skunk
Tuning Addict
Posts: 391
Joined: Sat Jun 25, 2011 2:30 pm
Location: Newmarket, ON

Re: Looking for adx/data logging help!

Post by skunk » Sat Mar 24, 2018 6:15 am

It's been awhile since I looked but I believe you need to start emulation and start recording.

John
1987 Turbocoupe.
A3M1/A9L, BE/EA, Tweecer RT.
306,Single Turbo, Ported E7's, Ported Stock Intake, 42lb Matched Green Tops, PMAS 3" Blow-Thru Protube (42# supercharger calibrated),T5z, 3.73 gears
..... Nothin Fancy.......Just something to keep me from the honey-do list.........

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Sat Mar 24, 2018 9:50 am

John, thanks for the reply. I believe that I've tried it both while emulating and not emulating, but I'll give it another shot today and see if that works.
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Sat Mar 24, 2018 4:15 pm

So I made some headway. I found a strategy file (GUFX_180124.xdf) that has a patch (Universal ADX Datalogging Patch), but it doesn't look like this adx supports the 8LD bin that I'm using. Is there a way to migrate this patch to the GUFA strategy file? I'm open to any suggestions. Thanks!
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

User avatar
skunk
Tuning Addict
Posts: 391
Joined: Sat Jun 25, 2011 2:30 pm
Location: Newmarket, ON

Re: Looking for adx/data logging help!

Post by skunk » Sun Mar 25, 2018 6:14 am

I cant help with your question but I can suggest a possible solution. Try writing a GUFB (A9L stick) or GUF1 (A9P auto) tune to the Quarterhorse and test that you have set up Tunerpro correctly. If it works...you could try building your tune on that that bin file. I don't have a quarterhorse but its been said many times that you can interchange GUFx bins on GUFx hardware using the quarterhorse successfully.

Good Luck
John
1987 Turbocoupe.
A3M1/A9L, BE/EA, Tweecer RT.
306,Single Turbo, Ported E7's, Ported Stock Intake, 42lb Matched Green Tops, PMAS 3" Blow-Thru Protube (42# supercharger calibrated),T5z, 3.73 gears
..... Nothin Fancy.......Just something to keep me from the honey-do list.........

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Mon Mar 26, 2018 8:56 am

John, sounds like a reasonable test. I'll give that a try this week and see if it works. There does seem to be more support for the A9L/GUFB strategy. Thanks for the suggestions!
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Wed Mar 28, 2018 3:34 pm

Ok, more headway.... but not quite there yet. So I loaded the A9L bin and the GUFX_180124 xdf file, applied the universal data logging patch, uploaded the bin, turned on the key, started the DA (data aquisition), opened the dashboard, selected EEC-IV and IT WORKED! I was seeing vbat, and could move the TP (throttle position) and everything was looking good. Thinking I was in the clear I went ahead and started the engine. All was well, I was seeing RPM, etc. all looking correct. But..... shortly thereafter, I'd estimate 10 seconds or so, the dashboard froze and I started getting connection errors in the DA status window. From there I had to disconnect the USB cable and re-initialize the hardware (QH) before I could get it working again. I've been through the scenario a few times now, but it always does the same thing. As long as I don't start the engine it will monitor correctly, but as soon as I start the engine I get connection errors within 0-20 seconds. So I'm back to my standard statement... any help would be appreciated!

Dave
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

User avatar
cgrey8
Administrator
Posts: 10569
Joined: Fri Jun 24, 2005 5:54 am
Location: Acworth, Ga (Metro Atlanta)
Contact:

Re: Looking for adx/data logging help!

Post by cgrey8 » Wed Mar 28, 2018 6:39 pm

I moved this topic over to SW Support instead of EECGeeks as this seems more fitting for the issues being discussed. EECGeeks is for the bin hackers to discuss code and firmware aspects of Ford EECs and less on helping people with their tuning and software issues.
...Always Somethin'

89 Ranger Supercab, 331 w/GT40p heads, ported Explorer lower, Crane Powermax 2020 cam, 1.6RRs, FMS Explorer (GT40p) headers, Slot Style MAF, aftermarket T5 'Z-Spec', 8.8" rear w/3.27s, Powertrax Locker, Innovate LC-1, GUFB, Moates QuarterHorse tuned using BE&EA

Member V8-Ranger.com

User avatar
skunk
Tuning Addict
Posts: 391
Joined: Sat Jun 25, 2011 2:30 pm
Location: Newmarket, ON

Re: Looking for adx/data logging help!

Post by skunk » Wed Mar 28, 2018 7:45 pm

Since your using TP and the adx from http://efidynotuning.com. You might want to verify your set-up in the getting started section.

Way down near the bottom there is a note regarding setting latency in device manager. If you didn't do this .....you may experience communication issues. I know I had to adjust latency to burn Moates chips or emulate with the Ostrich successfully.

John
1987 Turbocoupe.
A3M1/A9L, BE/EA, Tweecer RT.
306,Single Turbo, Ported E7's, Ported Stock Intake, 42lb Matched Green Tops, PMAS 3" Blow-Thru Protube (42# supercharger calibrated),T5z, 3.73 gears
..... Nothin Fancy.......Just something to keep me from the honey-do list.........

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Wed Mar 28, 2018 8:51 pm

One update, I found as long as I let the engine idle it stays connected, but as soon as I give it some gas it errors out within 10-20 seconds. I was able to monitor for ~10 min at idle no problem, but within 10 seconds of bringing up the RPMs it started to get errors. Any suggestions appreciated! Thanks

Dave
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Wed Mar 28, 2018 8:59 pm

John, thanks for the reply. I did see that setting the latency on the Com port to 1 was optional. I did try that, but I'll verify and try it again tomorrow. At least I'm seeing some data now. Making baby steps. Thanks again for the feedback!

Dave
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Tue Apr 03, 2018 10:59 am

Well, more updates, but not much progress. I tried it with both the latency set to 1 and default (16?) on the com port, no difference. I tried playing with the timeout and wait for silence settings in the Clear All and other commands, as well as trying the 'wait for silence' solution suggested elsewhere. This is where you insert a command that will 'wait for silence' into the gather data macro. Still no change. I tried another (faster) laptop, no change. My last attempt was to insert a 'Clear all' command into the gather data macro. It really didn't like that. It sent the entire ecm into limp mode soon after I started the motor. I'm running out of ideas, so as always, any suggestions appreciated.
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

User avatar
skunk
Tuning Addict
Posts: 391
Joined: Sat Jun 25, 2011 2:30 pm
Location: Newmarket, ON

Re: Looking for adx/data logging help!

Post by skunk » Tue Apr 03, 2018 1:14 pm

Dave.....I hate to say it but you may want to look for advice from the author of the adx. I tried to get it to work for a buddy last summer with his new Quarterhorse and experienced similar issues......he finally gave up and went with BE because I refused to tune with his buggy gear. Lol I would tune his quarterhorse with my Tweecer/BE license. Needless to say....he is very happy now.

The only other thing I can think of is trying another short high quality USB cable with a ferrule clipped on. Maybe its noise, maybe it's cable routing.....I'm guessing here.......my suspicions are the adx.

John
1987 Turbocoupe.
A3M1/A9L, BE/EA, Tweecer RT.
306,Single Turbo, Ported E7's, Ported Stock Intake, 42lb Matched Green Tops, PMAS 3" Blow-Thru Protube (42# supercharger calibrated),T5z, 3.73 gears
..... Nothin Fancy.......Just something to keep me from the honey-do list.........

davidsmcneill
Gear Head
Posts: 9
Joined: Fri Mar 23, 2018 7:30 pm

Re: Looking for adx/data logging help!

Post by davidsmcneill » Tue Apr 03, 2018 6:04 pm

John, thanks again for the suggestions. I'm heading to the local hot rod swap meet this weekend and I think I'll try to pick up an A9L or another similar ecu so I can swap that out and see if that helps. I'll give the USB cable a shot. I"ve got 2 ferrules on the USB cable coming out of the ecu, but nothing on the extension that goes to the laptop. I'll try swapping out the USB cable as well. I'll keep posting here with updates. Thanks again for the suggestions!
Factory Five MK4 with 95 Mustang drive train (5.0, T5, 8.8/3.31) and 93 Mustang fuel injection (8LD) running QH and a slightly modified BIN.

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests