Fuel pressure “issue”?

Anything about Ford EEC tuning. TwEECer and Moates questions dominate, but there's some SCT and OBD-II knowledge too.

Moderators: cgrey8, EDS50, 2Shaker, Jon 94GT

Post Reply
User avatar
scott88
Tuning Addict
Posts: 306
Joined: Thu Dec 09, 2004 6:00 pm
Location: Albany, NY

Fuel pressure “issue”?

Post by scott88 » Fri Jun 14, 2019 4:45 pm

Hi all, I was doing some driveway data logging this afternoon and noticed my fuel pressure was bobbing up and down at idle (is normally at 38 psi or so at idle) and nothing in the data log for fuel was changing at all. Then the gauge dropped to zero, but the car didn’t even sputter or change at all. AFR was steady- if I lost fuel pressure I assume the car would either go very lean or not even run, correct? I’m guessing the sending unit is faulty, since I shut it off and started it up again and the gauge was fine for a couple minutes then started acting fubar again. I have an auto meter full sweep 0-100 psi electrical gauge with sending unit hooked up.
A new sending unit is already on the way but I just wanted to verify if I was in fact losing pressure that I would see it in the datalog or the car wouldn’t even run at the very least.
Thanks,
Scott
88 Mustang LX, DSS 306, Moates QH v 1.6 w/self-tuned GUF1/A9P using BE & EA, Tremec 5 speed, LM-1 Wideband & Vortech S-trim, Crane 2031 cam, AFR 185 heads, Hooker longtubes, some other goodies.

User avatar
Vortech347
Tuning Addict
Posts: 303
Joined: Tue Sep 29, 2009 11:04 pm

Re: Fuel pressure “issue”?

Post by Vortech347 » Fri Jun 14, 2019 5:25 pm

Yeah, that's the sending unit. Check all your wiring, especially in the back of the gauge. The little pins have been known to come out.
Matt
90 GT, 347, Vortech Si-trim (11psi), Edelbrock 6037 heads, Super Victor 8.2 EFI Ported, 80MM Pmas, 60lb EV14 Bosch Gen 4 Injectors, KB BAP, B31 Cam, T56. Tweecer RT, A9L. Software: EA/BE. 550rwhp & 513rwtq.
2003 Sonic Blue 03' Cobra 497rwhp 481tq, Pro Racer Pack
2013 Taurus SHO Performance Pack.

User avatar
EDS50
Administrator
Posts: 3737
Joined: Sun Apr 05, 2009 9:17 am
Location: Tampa Bay, FL
Contact:

Re: Fuel pressure “issue”?

Post by EDS50 » Tue Jun 18, 2019 6:05 pm

The only thing I can add is to check the electrical connections on the control box that comes with the gauge if you have that style set up.
1992 LX - 25.1c Chassis, Vortech Blown Dart 332, Lentech Trans, TRZ Backhalf, A9L, Moates QH/SL v1.9, BE, EA, TunerView

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests