Do my O2 voltages/trims look right?

Anything about Ford EEC tuning. TwEECer and Moates questions dominate, but there's some SCT and OBD-II knowledge too.

Moderators: cgrey8, EDS50, Jon 94GT, 2Shaker

Post Reply
91GTman
Gear Head
Posts: 17
Joined: Mon Jun 13, 2005 5:19 pm
Location: Wilmington, NC

Do my O2 voltages/trims look right?

Post by 91GTman » Mon Jul 09, 2018 9:41 pm

Think I may have an O2 acting up. Have not been able to check for codes yet. In the log O2 voltages seem to jump drastically without afr moving much. thoughts?
Attachments
JONES 35 JULY dash 2018_Jul_08_17-12-48.csv
(1010.61 KiB) Downloaded 26 times
91 GT 5speed Black on Black
306* F303* Spyder Intake*42lbers* Edl RPMs* 75mm* 3" ATI MAF* DIY Turbo w/ GT42* 3"IC piping* Procharger FM Intercooler* Tweecer RT* BE* EA* 1/4 mi = 10.82 @ 125mph

91GTman
Gear Head
Posts: 17
Joined: Mon Jun 13, 2005 5:19 pm
Location: Wilmington, NC

Re: Do my O2 voltages/trims look right?

Post by 91GTman » Wed Jul 11, 2018 1:45 pm

Update:

I can feel the car surging as I watch the O2s swing. Its almost as they are causing it to pull too much fuel on lean swings. Increasing load and getting into open loop the cars runs normal. Also, forcing open loop the car drives fine at all loads. Hopefully, I can check codes and O2 this weekend...
91 GT 5speed Black on Black
306* F303* Spyder Intake*42lbers* Edl RPMs* 75mm* 3" ATI MAF* DIY Turbo w/ GT42* 3"IC piping* Procharger FM Intercooler* Tweecer RT* BE* EA* 1/4 mi = 10.82 @ 125mph

User avatar
skunk
Tuning Addict
Posts: 391
Joined: Sat Jun 25, 2011 2:30 pm
Location: Newmarket, ON

Re: Do my O2 voltages/trims look right?

Post by skunk » Thu Jul 12, 2018 6:58 am

Is this is for the turbo car in your signature? I assume based on the turbo listed your running a single.......where and how many Hegos are you running?

John
1987 Turbocoupe.
A3M1/A9L, BE/EA, Tweecer RT.
306,Single Turbo, Ported E7's, Ported Stock Intake, 42lb Matched Green Tops, PMAS 3" Blow-Thru Protube (42# supercharger calibrated),T5z, 3.73 gears
..... Nothin Fancy.......Just something to keep me from the honey-do list.........

91GTman
Gear Head
Posts: 17
Joined: Mon Jun 13, 2005 5:19 pm
Location: Wilmington, NC

Re: Do my O2 voltages/trims look right?

Post by 91GTman » Thu Jul 12, 2018 7:22 am

Yes. Running a single turbo, 4" downpipe. Tune is set for 1 hego and has been for 10 years now. The hego and wideband are 12" from the turbine with another 3 or 4 foot of pipe afterwards. This same setup has run well in closed loop for years which is why I am leaning towards an O2. I will get a chance to check the car tomorrow or Saturday.
91 GT 5speed Black on Black
306* F303* Spyder Intake*42lbers* Edl RPMs* 75mm* 3" ATI MAF* DIY Turbo w/ GT42* 3"IC piping* Procharger FM Intercooler* Tweecer RT* BE* EA* 1/4 mi = 10.82 @ 125mph

User avatar
skunk
Tuning Addict
Posts: 391
Joined: Sat Jun 25, 2011 2:30 pm
Location: Newmarket, ON

Re: Do my O2 voltages/trims look right?

Post by skunk » Thu Jul 12, 2018 9:32 am

Just had a quick look at the log you posted......lol, not an easy thing to do on a cell phone.

I don't think you have an O2 issue. Your loop status never changes from 1 and Kamrf is using stored correction causing minor drivability issues. Bottom line the log you posted never goes closed loop yet Hego switches several times due to on/off throttle position. Even the way Lambse is tracking looks like values from a fuel table and not the maxed valued based on failed sensor.

Verify your tune is set to go closed loop or check that you posted the correct log.

John
1987 Turbocoupe.
A3M1/A9L, BE/EA, Tweecer RT.
306,Single Turbo, Ported E7's, Ported Stock Intake, 42lb Matched Green Tops, PMAS 3" Blow-Thru Protube (42# supercharger calibrated),T5z, 3.73 gears
..... Nothin Fancy.......Just something to keep me from the honey-do list.........

91GTman
Gear Head
Posts: 17
Joined: Mon Jun 13, 2005 5:19 pm
Location: Wilmington, NC

Re: Do my O2 voltages/trims look right?

Post by 91GTman » Fri Jul 13, 2018 9:48 am

Yeh the first log was when i Forced OL to see if that would isolate the issue. Here is the log right before that one, where CL is allowed.
Attachments
JONES 35 JULY dash 2018_Jul_08_17-08-45.csv
(599.53 KiB) Downloaded 21 times
91 GT 5speed Black on Black
306* F303* Spyder Intake*42lbers* Edl RPMs* 75mm* 3" ATI MAF* DIY Turbo w/ GT42* 3"IC piping* Procharger FM Intercooler* Tweecer RT* BE* EA* 1/4 mi = 10.82 @ 125mph

User avatar
skunk
Tuning Addict
Posts: 391
Joined: Sat Jun 25, 2011 2:30 pm
Location: Newmarket, ON

Re: Do my O2 voltages/trims look right?

Post by skunk » Fri Jul 13, 2018 12:40 pm

I could be wrong but it looks like your Hegos are ok to me......your wideband on the other hand seems to have issues. It didn't seem to come alive untill around half way through the log. Likely time to replace that sensor.

When it did appear to be working it did move in direction of comanded Lambse when switching occurred. Albeit always indicating lean as does Lambse. I also don't know what your normal operating temperatures are.....it seems your running cold and your fuel will be sloppy untill you get warmer.

If nothing has changed and wbo2/Hego check out.....make sure everything is sealed up tight. Do a pressure test on the intake starting at the filter in let. If this was a new tune ....I'd be inclined to tell you your CL fuel needs work.

Please keep us posted....I'm curious what you find.

John
1987 Turbocoupe.
A3M1/A9L, BE/EA, Tweecer RT.
306,Single Turbo, Ported E7's, Ported Stock Intake, 42lb Matched Green Tops, PMAS 3" Blow-Thru Protube (42# supercharger calibrated),T5z, 3.73 gears
..... Nothin Fancy.......Just something to keep me from the honey-do list.........

91GTman
Gear Head
Posts: 17
Joined: Mon Jun 13, 2005 5:19 pm
Location: Wilmington, NC

Re: Do my O2 voltages/trims look right?

Post by 91GTman » Thu Jul 19, 2018 8:49 am

update...

put a scanner on and pulled two 11 codes (system passes). one for key on test and one for continuous memory. No koer codes. At this point I am going to get a O2 for my own sanity and also do the leak test. If that doesn't fix it I will start diving back into the tune.
91 GT 5speed Black on Black
306* F303* Spyder Intake*42lbers* Edl RPMs* 75mm* 3" ATI MAF* DIY Turbo w/ GT42* 3"IC piping* Procharger FM Intercooler* Tweecer RT* BE* EA* 1/4 mi = 10.82 @ 125mph

Post Reply

Who is online

Users browsing this forum: No registered users and 19 guests